Symptoms

  • Multiple Windows devices are not seen in the console.
  • The device_uuid value in the Automox agent log is identical for multiple devices.
  • These devices were cloned from a gold image.

Cause

Devices can merge records in Automox when too many unique identifiers in the device fingerprinting process match. This can happen when a computer is cloned from another without prepping the gold image beforehand.

The devices may have different hostnames, IP addresses, and MAC addresses. However, some important identifiers (such as the OS's SMBIOS UUID) may have been left unchanged when the original device was sealed and cloned.

When Automox generates an Agent UUID for a device (which differs from the OS UUID), and more than 40% of the device's variables match those of another device, Automox assigns the same Agent UUID to both devices. This can (and often does) cause problems.

Additional information: Automox UUID Generation Guide

Validate the device_uuid

The Automox agent log can be used to find the unique identifier used to report to the console. If this value is the same between two devices, there will be an issue with managing it.

  • Open the amagent.log file: Display the amagent.log in the Activity Log for Windows
  • Search for the "device_uuid" value to see the UUID issued to the agent.
  • This UUID can be searched for on the Devices page in the Automox console.
  • Compare the value with other devices that are not showing up in the console.

Validate the SMBIOS UUID

Check the following variable between the systems to confirm this value is the same and is causing an overlap:

Get-CimInstance -Class Win32_ComputerSystemProduct | Select-Object UUID

If the two systems have identical OS UUID values, they will struggle to have unique entries in the console. Follow the listed Solutions in this article.

If the two systems have unique OS UUID values, the following steps may resolve the issue when run on each device:

Stop-Service -Name "amagent"
amagent --deregister
Start-Service -Name "amagent"

Solution - Process Change

This situation can be caused by a missed step during generalization or preparation of the OS image before sealing.

Review Atuomox's recommended step on preparing an image: How to Create a Gold Image VM

Solution - Manual Fix

Unlike the Linux OS UUID, the Windows SMBIOS UUID cannot be changed via a command. Some VM hypervisors allow you to change the SMBIOS UUID through their application, but this can be an invasive process.

The cleanest option may be to open the gold image, correctly generalize it, and then recreate the VMs.

If that is not an option, the following steps may be able to change enough of the identifying data to generate a unique Automox UUID:

  1. Shut down the amagent service on all devices sharing a UUID.
  2. Deregister the agent on the devices via PowerShell: amagent --deregister
  3. Remove/Uninstall the agent on the devices: Removing the Automox Agent
  4. Make any necessary changes to separate the devices. Please note these are the variables we use to identify devices:

    const HARDWARE_ID_UUID = 'uuid'; // windows
    const HARDWARE_ID_MACHINE_ID = 'machine-id'; // non-windows
    const PROCESSOR_HASH = 'processor-hash';
    const MEMORY_HASH = 'memory-hash';
    const BIOS_HASH = 'bios-hash';
    const SYSTEM_HASH = 'system-hash';
    const HOSTNAME_INFO = "hostname-info";
    const IP_ADDRESS_ID = 'ipaddress-info';
    const MAC_ADDR_INFO = 'macaddr-info';
    const DISK_INFO = 'disk-info';
    const MINIMUM_MATCH_PERCENT = 40;

    These changes must be made while the device does not have the agent installed. You may need to restart the device as well after the changes have been made, then you can move on to Step 5.

    Additional information: Automox UUID Generation Guide

  5. Reinstall the agent: Automox Agent Installation Overview

When the newly installed agent starts on these devices, they should now have unique Automox UUIDs. 

Additional Reference

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