Issue Summary
Devices may appear missing or disconnected in the Automox console if the --deregister command has been executed. This action removes the local access key, preventing the agent from authenticating with the platform.
Diagnosis
To confirm if a missing access key is the root cause, check the local agent logs:
Navigate to:
C:\ProgramData\amagent\amagent.log-
Search the log file for the following strings:
access key is missing or invalid
This can also be easily done with the following Powershell command (running as Administrator):
(Select-String -Path "C:\ProgramData\amagent\amagent.log" -Pattern "access key is missing or invalid" -CaseSensitive:$false | Select-Object -Last 1).LineIf these entries are present and recent, proceed to the resolution steps below.
Resolution
You can restore connectivity by manually resetting the access key via PowerShell.
[!IMPORTANT] You will need your organization's unique Access Key found in the Automox Console under Settings > Keys. Note that Access Keys are Organization Specific.
Step-by-Step Instructions
-
Open PowerShell:
Launch an Administrative PowerShell prompt.
-
Stop the
amagentService in services.msc or with the following command:net stop amagent -
Set the New Access Key:
Replace
YOURACCESSKEYHEREwith your Automox Access Key and run the following command:& "C:\Program Files (x86)\Automox\amagent.exe" --setkey YOURACCESSKEYHERE -
Start the
amagentService in services.msc or with the following command:net start amagent
This can be executed in a single script:
net stop amagent
& "C:\Program Files (x86)\Automox\amagent.exe" --setkey YOURACCESSKEYHERE
net start amagent